Skip to content


HOGRE 0.1.0 on Ubuntu 10.10

Antti Salonen was so kind to guide me through the HOGRE installation. This is an installation guide for HOGRE on Ubuntu:

If you already have libogre-dev installed check that you have OGRE version 1.7.1

$ pkg-config --modversion OGRE
1.7.1

If not, add the following repository to the apt sources and install the OGRE SDK:

sudo apt-add-repository ppa:ogre-team/ogre
sudo apt-get install libogre-dev

(from OGRE3D SDK Downloads -> OGRE 1.7.1 Ubuntu PPA)

To install HOGRE using cabal do:

cabal update
cabal install cgen
PATH=$PATH:~/.cabal/bin
export PATH
cabal install hogre
cabal install hogre-examples

Try the HOGRE examples with:

cd ~/.cabal/share/hogre-examples-0.1.0
~/.cabal/bin/example_01
~/.cabal/bin/example_02

You should see something like this:

Thank you Antti Salonen for your help and HOGRE!
Official HOGRE website, HOGRE API

Tagged with .


0 Responses

Stay in touch with the conversation, subscribe to the RSS feed for comments on this post.



Some HTML is OK

or, reply to this post via trackback.